Emails Land in Spam Box 😐

Status
Not open for further replies.

Edwin

Member
Hey there,

Well, here's my 1st post :)

Sending test emails (e.g. Pabbly webhook trigger > use mapped out fields in Gmail to send an email) land in the Primary box.

Use case and apps: Stripe + DocsCloud + Pabbly Connect + Gmail

1. I send an invoice via Stripe
2. Client pays the invoice
3. DocsCloud workflow builder > get customer details via a webhook and assign them to the variables in the DocsCloud document (Name, Business Name, etc.)
4. DocsCloud workflow builder > create a document and send data via a webhook to Pabbly: Name, Email, Unique document link to be signed.
5. Pabbly Webhook trigger > get this data and map out the fields to send an email via Gmail.
6. Save and send test request > works perfectly, the email with the sign request lands in the Primary box.
7. I click "Save" and the Pabbly workflow is done.
8. I send a test invoice to test this flow.
9. Now the email with the sign request lands in the Spam box.

Some info:

- Domain: Google
- Email provider: Google
- Email-id is just 3 weeks old, also warming this up

Although the email account is just 3 weeks old, the test emails DO land in the Primary box.

Does anyone know the solution?

Thanks,
Edwin
 

Edwin

Member
--- SOLVED ---

I chose Gmail as a Pabbly action to send emails because I'm sending from my Google domain. But I had to choose SMTP by Pabbly (and also had to create a custom password for Pabbly due to having 2-step verification)
 
Status
Not open for further replies.
Top