1st Task - fail - WP tp Blogger

Look

Member
Hey,

I'm new to Pubbly. I just registered to test it out and I failed. It says "partial failed". Info:

Step Name: Google Blogger > Create a Post
Task Error Detail:

{
"error > code": 400,
"error > message": "Invalid JSON payload received. Unknown name \"\": Root element must be a message.",
"error > errors > 0 > message": "Invalid JSON payload received. Unknown name \"\": Root element must be a message.",
"error > errors > 0 > reason": "invalid",
"error > status": "INVALID_ARGUMENT",
"error > details > 0 > @type": "type.googleapis.com/google.rpc.BadRequest",
"error > details > 0 > fieldViolations > 0 > description": "Invalid JSON payload received. Unknown name \"\": Root element must be a message."
}

My aim is to publish a post that has been published on my WordPress blog, on my Blogger, ideally with a link back to my WP post.

Could you please help me with this?

I watched this video
and still I'm getting the error.

My posts include videos and I'm not sure what does "For youtube post map EmbedHtml code here. Use List Video by ID action of YouTube to get EmbedHtml code." mean.
 
Last edited:

Supreme

Well-known member
Staff member
Hey @Look

It seems like you haven't passed the label in double-quotes and because of that, you have the error occurs.

Though we have made the correction for you and it is working fine now. Kindly try again and let us know if that works for you.

2022-02-10_12h25_54.png
 

Look

Member
Hey @Supreme

Thank you for getting back to me and for the correction, but it's still not working.
I switched to another Blogger blog for testing purposes, and when I published a post on my WordPress, the post that has been published on Blogger was a test Hello World post - not the actual post, and when I posted another post on WordPress, on the Blogger nothing was published.

Moreover, when I checked the History on Pabbly, every action had (and still has) the Partial Failed status.

Please let me know how it can be fixed. I noticed every time is the Hello World test post instead of the real content or nothing.

I also get emails saying: "
Hello Lukasz Kubow,
This email is to notify you that for the workflow "RSS To Blogger 1" , a recent task was not executed due to following error -"​
Task Error Detail:

{
"error > code": 400,
"error > message": "Invalid JSON payload received. Unknown name \"\": Root element must be a message.",
"error > errors > 0 > message": "Invalid JSON payload received. Unknown name \"\": Root element must be a message.",
"error > errors > 0 > reason": "invalid",
"error > status": "INVALID_ARGUMENT",
"error > details > 0 > @type": "type.googleapis.com/google.rpc.BadRequest",
"error > details > 0 > fieldViolations > 0 > description": "Invalid JSON payload received. Unknown name \"\": Root element must be a message."
}
 
Last edited:

Supreme

Well-known member
Staff member
Hey @Look

From WordPress, the content is coming with HTML tags which were causing invalid JSON errors in the Google Blogger. Though to remove the HTML tags we have added a "Text Formatter by Pabbly: Text (Basic Formatting)" which will remove the tags from the content and pass it into simple text.

Kindly try again and let us know if that works for you.

2022-02-11_11h14_39.png


2022-02-11_11h17_40.png
 

Look

Member
Hey @Supreme
Thank you for adding the text block, but it's not working correctly.

I gave it a few days to run, but the content being posted on the Blogger blog is nothing like the original.
It's just posting dead URLs that are not even live links, not mentioning the embedded videos.

I'd like the Blogger posts to be like the original ones, with a live link back to the original.

This is how the post looks like https://csotam.blogspot.com/2022/02/moombahton-type-beat-2002-x-dj-snake.html
This is how it should look like https://jimmiessweetvideos.blogspot.com/2022/02/moombahton-type-beat-2002-x-dj-snake.html
(I used IFTTT for this, so I believe it should be possible by using Pabbly as well).

Could you please help me with this?
 

Supreme

Well-known member
Staff member
Hey @Look

For a youtube post, you need to replace the double quotes with a single quote and a <br> tag then you can post the video on Blogger. So, kindly try again and let us know how it works for you.

Though we have already made changes for posting the video links in your workflow. Further, you need to design your post by yourself or you can appoint an automation expert for that.
 

Look

Member
Hey @Supreme

Great, thank you so much for your help.

Looks good now, just if you could help me with one last thing: how I can make the "from links" (pointing back to the source) live, so they were actual links, not just raw URLs, then it would be great. I could then just clone the workflow be all set.

Could you please help me with this one last thing? It's all I need to set up the whole thing and buy the subscription as I'd like to move some of my stuff from IFTTT to Pabbly.

EDIT: I was just trying to figure it out by myself by cloning the workflow you've been helping me with, but the cloned one is not working like the original one, even without any change. What I'm doing wrong? Do I need to re-connect something in order for cloned workflows to work?
 
Last edited:

Supreme

Well-known member
Staff member
Hey @Look

Looks good now, just if you could help me with one last thing: how I can make the "from links" (pointing back to the source) live, so they were actual links, not just raw URLs, then it would be great. I could then just clone the workflow be all set.

As per your use case, we would suggest you try the "Data Forwarder by Pabbly: Return Workflow Response to the Source" action step.

Further, for a better understanding, you can refer to our tutorial video. Kindly try this at your end and let us know if that works for you.

 

Look

Member
Hey @Supreme

I will try several things, but could you please answer my question regarding why cloned workflows don't work?
Do I need to re-connect anything or do anything more in order for the cloned workflows to work?

I need the content from the main WordPress to post on several Blogspot blogs and it would be great just to clone a workflow and change only the destination blog.
 

Supreme

Well-known member
Staff member
Hey @Look

After cloning the workflow the webhook URL would get unique and since the cloned workflows' webhook URL is not set up in your workflow it wouldn't work.

So, to make your cloned workflow work, you need to set the webhook URL again.
 

Look

Member
Hey @Supreme

Thank you for the info. I have no idea what's the recent video is about as I'm not a dev. nor a coder, but I tried several things,
contacted a developer on Fiverr and so far nobody is able to tell how to make the link live.

Is it even possible with Pabbly?

One of the things I was trying to do was surrounding the mapped URL with HTML to create the link, as I do in IFTTT, but I was getting an error.
Like this <a href="MAPPED POST">MAPPED POST</a>
 
Last edited:

Supreme

Well-known member
Staff member
Hey @Look

Could you please record a short video of your concern once, so that we can look into it and can assist you accordingly? Also, <a href="MAPPED POST">MAPPED POST</a> works in the action event which has been added to your workflow and kindly try again at your end.
 

Look

Member
Hey @Supreme

Thank you for your reply, I just wanted to do everything you have written, but by the every Text step/box I can see this info:

akkkk.jpg


akkkk.jpg

I didn't touch this so how this got deprecated and how do I update it?
 

Supreme

Well-known member
Staff member
Hey @Look

I just wanted to do everything you have written, but by the every Text step/box I can see this info:

akkkk.jpg


akkkk.jpg

I didn't touch this so how this got deprecated and how do I update it?

The mark which you are seeing means that the action event is deprecated and there would a new version of the same action is now available. It is recommended to use the newer version.

The old versions are not removed until 10-12 months so you can continue to use them in the meantime and it will work normally. When you have the time it's good to upgrade to the newer versions of the same endpoint.
 

Look

Member
Thank you for the info @Supreme and for your help.

I think I got everything I needed.

I'll do some more tests and open a new thread or continue this one if needed.

Thank you once again for your help and for your patience.

Cheers!
 
Top