• Instructions to Ask a Question

    Click on the "Ask a Question" button and select the application for which you would like to ask questions.

    We have 5 different products namely - Pabbly Connect, Pabbly Subscription Billing, Pabbly Email Marketing, Pabbly Form Builder, Pabbly Email Verification.

    The turnaround time is 24 hrs (Business Hours - 10.00 AM to 6.00 PM IST, Except Saturday and Sunday). So your kind patience will be highly appreciated!

    🚀🚀Exclusive Discount Offer

    Just in case you're looking for any ongoing offers on Pabbly, you can check the one-time offers listed below. You just need to pay once and use the application forever -

    🔥 Pabbly Connect One Time Plan for $249 (🏆Lifetime Access) -  View offer 

    🔥 Pabbly Subscription Billing One Time Plan for $249 (🏆Lifetime Access) - View offer

Spreadsheet ID doesn't work

Ori D

Your Task History ID

I tried to run a workflow that the Pabbly Connect should recognize the Spreadsheet by its ID. As it should be dynamic. Unfortunately, for some reason it doesn't recognize it.

I tried to run the add new row and add multiple rows, but it didn't work in both cases. However, when I ran these steps manually, it worked. Also, I tried to run these steps by their name and not their ID, it also worked.

By the way, in order to find the ID of the Spreadsheet I tried to run two different action steps like: Global search and Search a spreadsheet. In both cases, it found the Spreadsheet ID. But when I tried to add a row by using the same ID I found in both action steps, it didn't work. In the history of this workflow I got an error: 400.

Please check this workflow URL: https://connect.pabbly.com/workflow/mapping/IjU3NjUwNTY5MDYzZjA0MzI1MjY4NTUzYzUxMzQi_pc

Thank you!


Well-known member
Staff member
Hey @Ori D

As we can see from your workflow, it seems like your Google Sheets action step didn't respond at that moment. Perhaps due to excessive application requests or maybe the data that
you were trying to fetch doesn't exist or unable to access it.

You can re-execute the task again and it will work again.

Ori D

Hi, thank you for your quick reply.

Sorry, but I tried to re-execute the task, but it didn't work. I get the same error 400.

Also, I tried to fetch the data from the form itself (step 1) so the data should be existed. Still it didn't work.

This is the error I have received:



Ori D

By the way, I also tried another option which I hadn't changed and worked before. Now it doesn't work for the same reason.

This is the workflow ID:




Well-known member
Staff member
Hey @Ori D

It seems that the spreadsheet ID you've mapped from the specific key is receiving the folder ID instead of the spreadsheet ID. As a result, the "Add multiple Row Values" operation is affected.


Our recommended solution is to select the file type as Google Sheets only. This option will limit the associated values with the name from your Google Drive to only Google Sheets.