• Instructions to Ask a Question

    Click on the "Ask a Question" button and select the application for which you would like to ask questions.

    We have 5 different products namely - Pabbly Connect, Pabbly Subscription Billing, Pabbly Email Marketing, Pabbly Form Builder, Pabbly Email Verification.

    The turnaround time is 24 hrs (Business Hours - 10.00 AM to 6.00 PM IST, Except Saturday and Sunday). So your kind patience will be highly appreciated!

    🚀🚀Exclusive Discount Offer

    Just in case you're looking for any ongoing offers on Pabbly, you can check the one-time offers listed below. You just need to pay once and use the application forever -

    🔥 Pabbly Connect One Time Plan for $249 (🏆Lifetime Access) -  View offer 

    🔥 Pabbly Subscription Billing One Time Plan for $249 (🏆Lifetime Access) - View offer

Asana "not an array" error for "creat a task"


I'm getting error message "projects: not an array" on a "create a task" action. Here's a screenshot of the action. It's pulling project ID from a previous Asana action.


Any help is appreciated.
Hi @Fagun Shah,

I'm not sure what you mean here. I pulled the project ID from a previous action. The previous action duplicates an existing project & then there was this "data new project gid" field from the results of that, which I assume is the project ID of the new project. Are you saying that's the wrong field to use? If so, which field should I use?

This workflow is now crashing every time I try to open the page. I get "page unresponsive" error and I can see in Task Manager, the memory usage just climbs until the page crashes.... so I'm unable to look at or edit this workflow. I commented in another thread about this issue. Hopefully @Supreme can help with this, so I can try the suggested fix.
@Supreme, I have the exact issue as described by @lifeinjamisty when creating an Asana Workflow.

I have been able to get most workflow steps to work correctly apart from Create a Task. I have tried various ID variables but I keep getting the same error msg. Projects. Not an array. Yet, I can pass the same variable in the final step and create a Section in the project successfully? Not sure if you can provide some guidance as to what I am doing wrong.

I have added the [" variable id ]" but I get the same partial error?
asana wk flow.png


Well-known member
Staff member
Hey @Patrick.Hall

It seems that the configuration of the action step was not completed in a single attempt, which resulted in an inaccurate passage of the previously configured project ID.

We have taken the necessary steps to rectify this issue, and it now appears to be functioning as expected. We kindly request that you review the configuration to ensure it is satisfactory and inform us of any further adjustments needed.
Thanks so much, @Supreme for actioning this so swiftly. It is appreciated.
Can you also show me how to format certain text inserted into Asana Task?

I would like to bold some text. I have tried the HTML tab <b> Notes:</b> but that does not work.


Well-known member
Staff member
I would like to bold some text. I have tried the HTML tab <b> Notes:</b> but that does not work.
Certainly, it is possible to include HTML tags within the "Note" field when using the "Create Task" action step. This allows you to verify and ensure the desired HTML formatting within the note using the HTML editor.