Webhook fields not updating


New here... trying out Pabbly to replace Zapier

I created my first workflow to catch a webhook from an Apple Shortcut and save the data in a Google Sheet.

The first time I set it up it worked fine, but after it ran I realized that I had incorrectly named one of the fields in my Shortcut. I fixed the issue but the catch Webhook step is still somehow got the wrong data. I tested whether it was something wrong with the Shortcut by displaying the data in an alert and it is fine. I can see the webhook *is* getting new data, it's just in the wrong fields and mislabeled.

I tried deleting and recreating the workflow, that didn't help.
I tried disconnecting and reconnecting my Google account, that didn't help.

Any ideas why this is happening and how to fix?


Well-known member
Staff member
Hey @jochi

Have you tried capturing the same data on the webhook.site application. So, in that way, you might get the data what type of data you are receiving from the triggering application.

You may refer to the following video on how you can use it.