• Instructions to Ask a Question

    Click on the "Ask a Question" button and select the application for which you would like to ask questions.

    We have 5 different products namely - Pabbly Connect, Pabbly Subscription Billing, Pabbly Email Marketing, Pabbly Form Builder, Pabbly Email Verification.

    The turnaround time is 24 hrs (Business Hours - 10.00 AM to 6.00 PM IST, Except Saturday and Sunday). So your kind patience will be highly appreciated!

    🚀🚀Exclusive Discount Offer

    Just in case you're looking for any ongoing offers on Pabbly, you can check the one-time offers listed below. You just need to pay once and use the application forever -
     

    🔥 Pabbly Connect One Time Plan for $249 (🏆Lifetime Access) -  View offer 

    🔥 Pabbly Subscription Billing One Time Plan for $249 (🏆Lifetime Access) - View offer

The new feature "enable ignoring Error" screwed all my workflows up :(

Status
Not open for further replies.

blueli

Member
Today my clients told me some workflows suddenly not working. Turns out workflow some of the tasks are skipped because of an error from a previous task. And then I learn there is a new feature "enable ignoring Error" to make the workflow keep going.
But I don't understand why it should not be enabled by default instead. Now it is potentially causing many of the workflows stopped to work because we have not turned it on immediately since it was released.
The attached images show. The same error from a task causes different results. One keeps going the other one is skipped and causing an airtable record is not created.
Now I have to review all workflow and see which task should be enabled ignoring errors, which not needed.

Do you experience the same struggle or just me?
😫


Any way It is better to keep everything going when an event of an error than to skip without any notice.
It is very time wasted and stressful for me right now. I don't know which lead import was skipped and needed to be re-executed.

Screenshot 2023-05-31 at 4.20.47 PM.png

Screenshot 2023-05-31 at 4.31.13 PM.png
 

Supreme

Well-known member
Staff member
Yes, we have introduced the "Enable Ignoring Error" feature on our platform to provide you with enhanced control and flexibility in your workflow automation. This new feature, specifically the Skip Step on Failure capability, allows you to optimize your processes by automatically excluding any step that is associated with a failed step during execution. This means that you can eliminate the unnecessary consumption of resources on failed tasks, ensuring a more efficient and streamlined workflow.

By utilizing Skip Step on Failure, you not only save valuable time and effort but also address the issue of incomplete or missed data within your application. This feature helps to ensure that your workflows are executed smoothly without interruptions caused by errors, improving the overall reliability and accuracy of your automation.

We understand that in some cases, you may prefer not to ignore the missed mapped data in the action step. In such scenarios, you can easily utilize the "Disable Ignoring Error" option. By using this option, you can ensure that any missed mapped data is not overlooked, providing you with greater control over the process and allowing you to maintain the integrity of your data.

1685528834249.png


Overall, these features aim to optimize your workflow automation experience by minimizing resource consumption, eliminating incomplete or missed data, and empowering you to make informed decisions about handling errors. By integrating the "Enable Ignoring Error" feature into your workflow, you can achieve greater efficiency and reliability while maximizing the utilization of our system resources.

Additionally, you can check here for more details on which action step is involved and how the automation will operate.
 

blueli

Member
How do we know when to enable it? There are so many scenarios to cause errors. Why should we not enable Ignoring Error for every step?
 

Supreme

Well-known member
Staff member
How do we know when to enable it? There are so many scenarios to cause errors. Why should we not enable Ignoring Error for every step?

We regret to inform you that activating this feature by default is not possible due to the potential risks associated with workflow execution. Allowing workflows to continue running even if a previous step fails can lead to the execution of subsequent steps with incorrect data from the failed step. This may result in unnecessary tasks being performed on failed steps, which goes against our objective of optimizing workflow efficiency.

However, we have provided a solution in the form of an option called "Enable Ignore Errors". If you encounter a specific step that continues to fail (as indicated by error notifications sent to your registered Pabbly account email address), and you still wish to proceed with executing the workflow despite the error, you have the option to "Enable Ignoring Error". This will allow the workflow to continue even if errors occur.

We believe that enabling "Ignore Errors" is the best recommendation we can offer in this situation.

1685605075653.png


Please let us know if we can help you with anything else.
 

blueli

Member
No. It does nothing for the router.
I have enabled ignore the error for both PrefexCRM Search Lead Step
The router could not run if no result is found. This really screwed my workflows. Now I dont know how to make it work. I have tried my best to ignore this new feature.
 

Attachments

  • Screenshot 2023-06-01 at 3.32.43 PM.png
    Screenshot 2023-06-01 at 3.32.43 PM.png
    250.8 KB · Views: 72

blueli

Member
Instead of using the prebuilt module, I tried API module. The same result. router is no longer working
Screenshot 2023-06-01 at 4.00.29 PM.png
 

Supreme

Well-known member
Staff member
Can you share the task history ID in which you have noticed the error in API by the Pabbly action step.
 

blueli

Member
You can read this thread if you have time Thanks

The way I do the router for the search lead result

Route A: I use "does not contain" if a record is not found
as the result there will be only 2 parameters there
Status: false
Message: No data were found

Therefore this "5. 0 id" is not going to be there if the record is really not found. (this is why the router is skipped, even though I have already enabled ignore on the search lead API step)

Route B: For if a record is found the condition would be
if "5. 0 email: blue example.com" is equal to "1. webhook. email: blue at example.com"

Screenshot 2023-06-01 at 4.24.43 PM.png
 
Last edited:

blueli

Member
Task History ID - IjU3NjAwNTZiMDYzNjA0MzQ1MjY5NTUzYzUxM2I1M
This is one of the not working tasks
 
Last edited:

Supreme

Well-known member
Staff member
Instead of using the prebuilt module, I tried API module. The same result. router is no longer working
Screenshot 2023-06-01 at 4.00.29 PM.png

Regarding Router related issues we have made some changes from our end and it should work accordingly now. So, you can try executing the tasks again.

Therefore this "5. 0 id" is not going to be there if the record is really not found. (this is why the router is skipped, even though I have already enabled ignore on the search lead API step)

Route B: For if a record is found the condition would be
if "5. 0 email: blue example.com" is equal to "1. webhook. email: blue at example.com"
Further, in the "Record Not Found" route action step we have disabled the ignore error feature. So, it should work accordingly now.

2023-06-01_16h58_52.png



Task History ID - IjU3NjAwNTZiMDYzNjA0MzQ1MjY5NTUzYzUxM2I1MTYwNTQzOSI_3D_pc
This is one of the not working tasks
Along with this task history, it didn't run because the person's email address which you are finding from the API by the Pabbly action step didn't get found from the application which leads to running the 3 routers (Add Mailchimp) as a result the users was already been in your MailChimp which is why Mailchimp action step has also thrown that error.

1685619995631.png


1685619972134.png
 

blueli

Member
//Regarding Router related issues we have made some changes from our end and it should work accordingly now. So, you can try executing the tasks again.

Hi. I have checked. and rematched some field which I have forgot to do it when I replaced the search step from prebuilt module to API module for the workflow. and re-executed a task.

Supposed it should be running if no lead is found from the API Search Lead Step then add a new lead to the CRM via the route A: API step.
However, the route A: Record Not Found is still being skipped after you have made some changes from your end

Task History ID - IjU3NjAwNTZiMDYzNjA0Mzc1MjY4NTUzNTUxMz

Please take a look Thanks

Screenshot 2023-06-01 at 10.57.54 PM.png
 
Last edited:

blueli

Member
Task History ID - IjU3NjAwNTZiMDYzNjA0Mzc1MjY4NTUzMjUxMzE1MT
Here I have another workflow with a similar search lead, not found do route A, found do route B.
Both workflow has no record found.
But this workflow router works, not being skipped. I am not sure why, some kind of bug?

Screenshot 2023-06-01 at 11.08.16 PM.png
 
Last edited:

blueli

Member
Sorry for rushing. In case this thread is forgotten. Would it be possible to have some update on this issue today?
This is really stressful for me right now. Because the router is skipped, the workflow used to work for months and now it is not able to run Route A which is creating new leads for the CRM.
Thanks
 

Supreme

Well-known member
Staff member
Here I have another workflow with a similar search lead, not found do route A, found do route B.
We have disabled the "Ignore Error" feature from all your action steps so, now can you give it a try, as we can see it is working fine.
 

blueli

Member
No... Not that one...
That one is working. With enabled ignore the error.
Below is the one that the router keeps being skipped. And shouldn't we enable the ignore the error so that the router will not be skipped?
Task History ID - IjU3NjAwNTZiMDYzNzA0MzQ1MjZmNTUzNjUxM
Screenshot 2023-06-02 at 5.25.59 PM.png
 
Last edited:

blueli

Member
I see you have disabled all Ignore Error for the steps which I don't understand. The aim is to keep the router going even with error...I re executed the task. The router is still skipped.
Here is the task for your reference. Thanks
Task History ID - IjU3NjAwNTZiMDYzNzA0MzQ1MjY4NTUzZDUxMzM
 
Last edited:

blueli

Member
Hi. thank for the reply.
I have tested your updated workflow. And it seems to work as before. I have 2 questions.

#1 One thing I need to know. Did you only modify my workflow or has your team tweaked something from your end therefore the router is no getting skipped?

I noticed you changed the condition. From if a field does not exist to If the email does not contain @.
Screenshot 2023-06-03 at 5.39.41 PM.png



I changed that condition back to my origin setup. It also seem to work too.
Screenshot 2023-06-03 at 5.41.49 PM.png



#2 Do you think if it is safe to keep using "does not exist" for my route condition?
Becuase I have some other workflow doing the similar, but not having email data for the search result.

Thanks
 
Status
Not open for further replies.
Top